Knowledgebase
MISys Technical Support > Help Desk > Knowledgebase

Search help:


Compatibility for Sage 50 US 2017 and Sage 50 US 2018

Solution

The current version of MISys (v6.4) is compatible with both versions Sage 50 US 2017 and Sage 50 2018. A complete list of supported accounting packages can be accessed here: 

http://misysinc.com/support/documents/pdf/MISys-Mfg-supported-accounting-packages.pdf

If you are running an older version of MISys and are interested in upgrading to the current version of MISys v6.4 please contact MISys Technical Support for a download link and instructions.

 
Was this article helpful? yes / no
Article details
Article ID: 87
Category: Accounting- Sage 50 US
Date added: Mar-30-2018: 10:23am
Views: 83
Rating (Votes): Article rated 3.0/5.0 (22)

 
« Go back